GLSA-200404-18 : Multiple Vulnerabilities in ssmtp

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200404-18
(Multiple Vulnerabilities in ssmtp)

There are two format string vulnerabilities inside the log_event() and
die() functions of ssmtp. Strings from outside ssmtp are passed to various
printf()-like functions from within log_event() and die() as format
strings. An attacker could cause a specially-crafted string to be passed to
these functions, and potentially cause ssmtp to execute arbitrary code.

Impact :

If ssmtp connects to a malicious mail relay server, this vulnerability can
be used to execute code with the rights of the mail sender, including root.

Workaround :

There is no known workaround at this time. All users are advised to upgrade
to the latest available version of ssmtp.

See also :

http://secunia.com/advisories/11378/
http://www.nessus.org/u?be198041
http://www.gentoo.org/security/en/glsa/glsa-200404-18.xml

Solution :

All users are advised to upgrade to the latest available version of ssmtp.
# emerge sync
# emerge -pv '>=mail-mta/ssmtp-2.60.7'
# emerge '>=mail-mta/ssmtp-2.60.7'

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14483 (gentoo_GLSA-200404-18.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0156