GLSA-200404-17 : ipsec-tools and iputils contain a remote DoS vulnerability

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200404-17
(ipsec-tools and iputils contain a remote DoS vulnerability)

When racoon receives an ISAKMP header, it allocates memory based on the
length of the header field. Thus, an attacker may be able to cause a Denial
of Services by creating a header that is large enough to consume all
available system resources.

Impact :

This vulnerability may allow an attacker to remotely cause a Denial of
Service.

Workaround :

A workaround is not currently known for this issue. All users are advised
to upgrade to the latest version of the affected package.

See also :

http://ipsec-tools.sourceforge.net/
http://www.gentoo.org/security/en/glsa/glsa-200404-17.xml

Solution :

ipsec-tools users should upgrade to version 0.2.5 or later:
# emerge sync
# emerge -pv '>=net-firewall/ipsec-tools-0.3.1'
# emerge '>=net-firewall/ipsec-tools-0.3.1'
iputils users should upgrade to version 021109-r3 or later:
# emerge sync
# emerge -pv '>=net-misc/iputils-021109-r3'
# emerge '>=net-misc/iputils-021109-r3'

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14482 (gentoo_GLSA-200404-17.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0403