GLSA-200404-04 : Multiple vulnerabilities in sysstat

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200404-04
(Multiple vulnerabilities in sysstat)

There are two vulnerabilities in the way sysstat handles symlinks:
The isag utility, which displays sysstat data in a graphical format,
creates a temporary file in an insecure manner.
Two scripts in the sysstat package, post and trigger, create temporary
files in an insecure manner.

Impact :

Both vulnerabilities may allow an attacker to overwrite arbitrary files
under the permissions of the user executing any of the affected
utilities.

Workaround :

A workaround is not currently known for this issue. All users are advised
to upgrade to the latest version of the affected package.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200404-04.xml

Solution :

Systat users should upgrade to version 4.2 or later:
# emerge sync
# emerge -pv '>=app-admin/sysstat-5.0.2'
# emerge '>=app-admin/sysstat-5.0.2'

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14469 (gentoo_GLSA-200404-04.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0107
CVE-2004-0108