GLSA-200403-14 : Multiple Security Vulnerabilities in Monit

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200403-14
(Multiple Security Vulnerabilities in Monit)

A denial of service may occur due to Monit not sanitizing remotely
supplied HTTP parameters before passing them to memory allocation
functions. This could allow an attacker to cause an unexpected
condition that could lead to the Monit daemon crashing.
An overly long http request method may cause a buffer overflow due to
Monit performing insufficient bounds checking when handling HTTP
requests.

Impact :

An attacker may crash the Monit daemon to create a denial of service
condition or cause a buffer overflow that would allow arbitrary code to
be executed with root privileges.

Workaround :

A workaround is not currently known for this issue. All users are
advised to upgrade to the latest version of the affected package.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200403-14.xml

Solution :

Monit users should upgrade to version 4.2 or later:
# emerge sync
# emerge -pv '>=app-admin/monit-4.2'
# emerge '>=app-admin/monit-4.2'

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14465 (gentoo_GLSA-200403-14.nasl)

Bugtraq ID: 9098
9099

CVE ID: CVE-2003-1083
CVE-2003-1084