Cfengine cfservd ReceiveTransaction Function Remote Overflow (version check)

This script is Copyright (C) 2004-2013 Tenable Network Security, Inc.

Synopsis :

The remote host is affected by a remote buffer overflow vulnerability.

Description :

Cfengine is running on this remote host.

This version has a stack-based buffer overrun vulnerability.

An attacker, exploiting this flaw, would need network access to the
server as well as the ability to send a crafted transaction packet to
the cfservd process. Successful exploitation of this flaw would lead
to arbitrary code being executed on the remote machine or a loss of
service (DoS).

See also :

Solution :

Upgrade to at least 1.5.3-4, 2.0.8 or most recent 2.1 version.

Risk factor :

High / CVSS Base Score : 7.5
CVSS Temporal Score : 6.2
Public Exploit Available : true

Family: Gain a shell remotely

Nessus Plugin ID: 14317 (cfengine_trans_packet_buff_overrun.nasl)

Bugtraq ID: 8699

CVE ID: CVE-2003-0849