phpBB < 2.0.10 Multiple XSS

This script is Copyright (C) 2004-2012 Tenable Network Security, Inc.


Synopsis :

A remote web application is vulnerable to cross-site scripting.

Description :

The remote host is running a version of phpBB older than 2.0.10.

phpBB contains a flaw that allows a remote cross-site scripting attack.
This flaw exists because the application does not validate user-supplied
input in the 'search_author' parameter.

This version is also vulnerable to an HTTP response splitting attack
that permits the injection of CRLF characters in the HTTP headers.

Solution :

Upgrade to 2.0.10 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:H/RL:OF/RC:ND)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 13840 ()

Bugtraq ID: 10738
10753
10754
10883

CVE ID: CVE-2004-0730
CVE-2004-2054
CVE-2004-2055