RHEL 2.1 / 3 : netpbm (RHSA-2004:031)

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

Updated NetPBM packages are available that fix a number of temporary
file vulnerabilities in the netpbm libraries.

The netpbm package contains a library of functions that support
programs for handling various graphics file formats, including .pbm
(portable bitmaps), .pgm (portable graymaps), .pnm (portable anymaps),
.ppm (portable pixmaps), and others.

A number of temporary file bugs have been found in versions of NetPBM.
These could make it possible for a local user to overwrite or create
files as a different user who happens to run one of the the vulnerable
utilities. The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the name CVE-2003-0924 to this issue.

Users are advised to upgrade to the erratum packages, which contain
patches from Debian that correct these bugs.

See also :

https://www.redhat.com/security/data/cve/CVE-2003-0924.html
http://rhn.redhat.com/errata/RHSA-2004-031.html

Solution :

Update the affected netpbm, netpbm-devel and / or netpbm-progs
packages.

Risk factor :

Low / CVSS Base Score : 3.7
(CVSS2#AV:L/AC:H/Au:N/C:P/I:P/A:P)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 12454 ()

Bugtraq ID:

CVE ID: CVE-2003-0924