RHEL 2.1 / 3 : iproute (RHSA-2003:317)

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing a security update.

Description :

Updated iproute packages that close a locally-exploitable denial of
service vulnerability are now available.

The iproute package contains advanced IP routing and network device
configuration tools.

Herbert Xu reported that iproute can accept spoofed messages sent on
the kernel netlink interface by other users on the local machine. This
could lead to a local denial of service attack. The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned the
name CVE-2003-0856 to this issue.

Users of iproute should upgrade to these erratum packages, which
contain a patch that checks that netlink messages actually came from
the kernel.

See also :

https://www.redhat.com/security/data/cve/CVE-2003-0856.html
http://rhn.redhat.com/errata/RHSA-2003-317.html

Solution :

Update the affected iproute package.

Risk factor :

Medium / CVSS Base Score : 4.9
(CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:C)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 12432 ()

Bugtraq ID:

CVE ID: CVE-2003-0856