RHEL 2.1 : semi (RHSA-2003:231)

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

Updated semi packages that fix vulnerabilities in semi's temporary
file handling are now available.

semi is a MIME library for GNU Emacs and XEmacs used by the wl mail
package.

A vulnerability in semi version 1.14.3 and earlier allows an attacker
to overwrite arbitrary files with potentially arbitrary contents using
the privileges of the user running Emacs and semi. The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned the
name CVE-2003-0440 to this issue.

Users of semi are advised to upgrade to these packages, which contain
a backported patch correcting this issue.

See also :

https://www.redhat.com/security/data/cve/CVE-2003-0440.html
http://www.debian.org/security/2003/dsa-339
http://rhn.redhat.com/errata/RHSA-2003-231.html

Solution :

Update the affected semi and / or semi-xemacs packages.

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 12408 ()

Bugtraq ID:

CVE ID: CVE-2003-0440