RHEL 2.1 : pine (RHSA-2002:271)

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.

Synopsis :

The remote Red Hat host is missing a security update.

Description :

A vulnerability in Pine version 4.44 and earlier releases can cause
Pine to crash when sent a carefully crafted email.

[Updated 06 Feb 2003] Added fixed packages for Advanced Workstation

Pine, developed at the University of Washington, is a tool for
reading, sending, and managing electronic messages (including mail and

A security problem was found in versions of Pine 4.44 and earlier. In
these verions, Pine does not allocate enough memory for the parsing
and escaping of the 'From' header, allowing a carefully crafted email
to cause a buffer overflow on the heap. This will result in Pine

All users of Pine on Red Hat Linux Advanced Server are advised to
update to these errata packages containing a patch to version 4.44 of
Pine that fixes this vulnerability.

See also :


Solution :

Update the affected pine package.

Risk factor :

Medium / CVSS Base Score : 5.0

Family: Red Hat Local Security Checks

Nessus Plugin ID: 12338 ()

Bugtraq ID:

CVE ID: CVE-2002-1320