RHEL 2.1 : php (RHSA-2002:129)

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

PHP versions earlier than 4.1.0 contain a vulnerability that could
allow arbitrary commands to be executed.

[updated 22 Aug 2002] The initial set of errata packages contained an
incorrect set of dependencies. This meant that a number of packages
would need to be installed before php that were not essential to the
operation of php. Updated errata packages are included with this
advisory that have corrected dependencies.

PHP is an HTML-embedded scripting language commonly used with Apache.
PHP versions 4.0.5 through 4.1.0 in safe mode do not properly cleanse
the 5th parameter to the mail() function. This vulnerability allows
local users and possibly remote attackers to execute arbitrary
commands via shell metacharacters.

Red Hat Linux Advanced Server version 2.1 shipped with PHP 4.0.6.

The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CVE-2001-1246 to this issue.

All users of PHP should upgrade to these errata packages containing
PHP 4.1.2, which is not vulnerable to this issue.

Note :

This PHP errata enforces memory limits on the size of the PHP process
to prevent a badly generated script from becoming a possible source
for a denial of service attack. The default process size is 8Mb though
you can adjust this as you deem necessary thought the php.ini
directive memory_limit. For example, to change the process memory
limit to 4MB, add the following :

memory_limit 4194304

Important Installation Note :

There are special instructions you should follow regarding your
/etc/php.ini configuration file in the 'Solution' section below.

See also :

https://www.redhat.com/security/data/cve/CVE-2001-1246.html
http://rhn.redhat.com/errata/RHSA-2002-129.html

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 12307 ()

Bugtraq ID:

CVE ID: CVE-2001-1246