RHEL 2.1 : xchat (RHSA-2002:124)

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing a security update.

Description :

A security issue in XChat allows a malicious server to execute
arbitrary commands.

XChat is a popular cross-platform IRC client.

Versions of XChat prior to 1.8.9 do not filter the response from an
IRC server when a /dns query is executed. Because XChat resolves
hostnames by passing the configured resolver and hostname to a shell,
an IRC server may return a maliciously formatted response that
executes arbitrary commands with the privileges of the user running
XChat.

All users of XChat are advised to update to these errata packages
containing XChat version 1.8.9 which is not vulnerable to this issue.

[update 14 Aug 2002] Previous packages pushed were not signed, this
update replaces the packages with signed versions

See also :

https://www.redhat.com/security/data/cve/CVE-2002-0382.html
http://rhn.redhat.com/errata/RHSA-2002-124.html

Solution :

Update the affected xchat package.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Red Hat Local Security Checks

Nessus Plugin ID: 12303 ()

Bugtraq ID: 4376

CVE ID: CVE-2002-0382