Apache 2.x < 2.0.50 Multiple Remote DoS

This script is Copyright (C) 2004-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by a denial of service.

Description :

The remote host appears to be running a version of Apache 2.x that is
prior to 2.0.50. It is, therefore, affected by a denial of service
vulnerability that can be triggered by sending a specially crafted
HTTP request, which results in the consumption of an arbitrary amount
of memory. On 64-bit systems with more than 4GB virtual memory, this
may lead to a heap based buffer overflow.

There is also a denial of service vulnerability in mod_ssl's
'ssl_io_filter_cleanup' function. By sending a request to a vulnerable
server over SSL and closing the connection before the server can send
a response, an attacker can cause a memory violation that crashes the

See also :


Solution :

Upgrade to Apache 2.0.50 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 12293 (apache_input_header_folding_dos.nasl)

Bugtraq ID: 10619

CVE ID: CVE-2004-0493