Apache < 1.3.31 / 2.0.49 Socket Connection Blocking Race Condition DoS

This script is Copyright (C) 2004-2012 Scott Shebby

Synopsis :

The remote web server is vulnerable to a denial of service attack.

Description :

The remote web server appears to be running a version of Apache that
is less that 2.0.49 or 1.3.31.

These versions are vulnerable to a denial of service attack where a
remote attacker can block new connections to the server by connecting
to a listening socket on a rarely accessed port.

Note that this issue is known to affect some versions of AIX, Solaris,
and Tru64 and known to not affect FreeBSD or Linux.

See also :


Solution :

Upgrade to Apache 2.0.49 or 1.3.31.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 12280 (apache_conn_block.nasl)

Bugtraq ID: 9921

CVE ID: CVE-2004-0174