CVS < 1.11.17 / 1.12.9 Multiple Vulnerabilities

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.

Synopsis :

The remote CVS server is affected by multiple issues.

Description :

The remote CVS server, according to its version number, might allow an
attacker to execute arbitrary commands on the remote system because of
a flaw relating to malformed Entry lines which lead to a missing NULL

Among the issues deemed likely to be exploitable were:

- A double-free relating to the error_prog_name string.

- An argument integer overflow. (CVE-2004-0417)

- Out-of-bounds writes in serv_notify. (CVE-2004-0418)

See also :

Solution :

Upgrade to CVS 1.12.9 or 1.11.17.

Risk factor :

High / CVSS Base Score : 7.1
CVSS Temporal Score : 5.9
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 12265 (cvs_malformed_entry_lines_flaw.nasl)

Bugtraq ID: 10499

CVE ID: CVE-2004-0414