CVS pserver Line Entry Handling Overflow

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.

Synopsis :

The remote version control service has a remote heap-based buffer
overflow vulnerability.

Description :

According to its version number, the remote CVS server has a heap-
based buffer overflow vulnerability. A remote attacker could exploit
this to crash the service, or possibly execute arbitrary code.

See also :

Solution :

Upgrade to CVS 1.12.8 / 1.11.16 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 8.3
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 12240 (cvs_pserver_heap_overflow.nasl)

Bugtraq ID: 10384

CVE ID: CVE-2004-0396