Courier < 0.45 Multiple Remote Overflows

This script is Copyright (C) 2004-2011 Tenable Network Security, Inc.


Synopsis :

The remote SMTP server has multiple buffer overflow vulnerabilities.

Description :

According to its version number, the version of Courier MTA running
on the remote host has multiple buffer overflow vulnerabilities. A
remote attacker could exploit this to crash the service, or possibly
execute arbitrary code.

Solution :

Upgrade to Courier 0.45 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: SMTP problems

Nessus Plugin ID: 12102 (courier_overflows.nasl)

Bugtraq ID: 9845

CVE ID: CVE-2004-0224