Apache-SSL SSLVerifyClient SSLFakeBasicAuth Client Certificate Forgery

This script is Copyright (C) 2004-2012 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by a client certificate forging
vulnerability.

Description :

The remote host is running a version of ApacheSSL that is older than
1.3.29/1.53. Such versions are reportedly vulnerable to a flaw that
could allow an attacker to make the remote server forge a client
certificate.

See also :

http://archives.neohapsis.com/archives/fulldisclosure/2004-02/0257.html
http://www.apache-ssl.org/advisory-20040206.txt

Solution :

Upgrade to ApacheSSL 1.3.29/1.53 or newer.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 12046 (apache_ssl_certificate_forging.nasl)

Bugtraq ID: 9590

CVE ID: CVE-2004-0009