mod_python < 2.7.9 / 3.0.4 Malformed Query String DoS

This script is Copyright (C) 2003-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is prone to a denial of service attack.

Description :

The remote host is using the Apache mod_python module older than 2.7.9
or 3.0.4. These versions may be prone to a denial of service attacks
when handling malformed queries.

See also :

http://www.modpython.org/pipermail/mod_python/2003-November/014533.html

Solution :

Upgrade to mod_python 2.7.9 / 3.0.4 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 11937 ()

Bugtraq ID: 9129

CVE ID: CVE-2003-0973