Apache < 2.0.48 Multiple Vulnerabilities (OF, Info Disc.)

This script is Copyright (C) 2003-2012 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

The remote host appears to be running a version of Apache 2.x which is
older than 2.0.48. Such versions are reportedly affected by multiple
vulnerabilities.

- The mod_rewrite and mod_alias modules fail to handle
regular expressions containing more than 9 captures
resulting in a buffer overflow.

- A vulnerability may occur in the mod_cgid module caused
by the mishandling of CGI redirect paths. This could
cause Apache to send the output of a CGI program to the
wrong client.

See also :

http://www.securityfocus.com/archive/1/342674/30/0/threaded
http://lists.apple.com/archives/security-announce/2004/Jan/msg00000.html

Solution :

Upgrade to Apache web server version 2.0.48 or newer.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 11853 (apache_2_0_48.nasl)

Bugtraq ID: 8926

CVE ID: CVE-2003-0789
CVE-2003-0542