LSH Daemon < 1.4.3 / 1.5.3 lshd Remote Overflow

This script is Copyright (C) 2003-2014 Tenable Network Security, Inc.


Synopsis :

The remote SSH server is affected by a buffer overflow vulnerability.

Description :

According to its banner, the version of LSH (a free replacement for
SSH) is a version prior to 1.4.3 / 1.5.3. It is, therefore, affected by
a buffer overflow vulnerability due to improper handling of user input
to the 'read_line.c', 'channel_commands.c', and 'client_keyexchange.c'
source files that could allow an attacker to execute arbitrary code or
cause a denial of service.

See also :

http://archives.neohapsis.com/archives/bugtraq/2003-09/0310.html
http://archives.neohapsis.com/archives/bugtraq/2003-09/0326.html

Solution :

Upgrade to LSH 1.4.3 / 1.5.3 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 11843 (lsh_overflow.nasl)

Bugtraq ID: 8655

CVE ID: CVE-2003-0826