This script is Copyright (C) 2003-2014 Tenable Network Security, Inc.
The remote SSH server is affected by a buffer overflow vulnerability.
According to its banner, the version of LSH (a free replacement for
SSH) is a version prior to 1.4.3 / 1.5.3. It is, therefore, affected by
a buffer overflow vulnerability due to improper handling of user input
to the 'read_line.c', 'channel_commands.c', and 'client_keyexchange.c'
source files that could allow an attacker to execute arbitrary code or
cause a denial of service.
See also :
Upgrade to LSH 1.4.3 / 1.5.3 or later.
Risk factor :
Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 8.3
Public Exploit Available : true