Horde IMP IMP_MIME_Viewer_html Class XSS

This script is Copyright (C) 2003-2011 George A. Theall


Synopsis :

The remote web server is affected by a cross-site scripting
vulnerability.

Description :

The remote server is running at least one instance of IMP whose
version number is between 3.0 and 3.2.1 inclusive. Such versions are
vulnerable to several cross-scripting attacks whereby an attacker can
cause a victim to unknowingly run arbitrary JavaScript code simply by
reading an HTML message from the attacker.

Note : Nessus has determined the vulnerability exists on the target
simply by looking at the version number of IMP installed there. If the
installation has already been patched, consider this a false positive.

See also :

http://marc.info/?l=imp&m=105940167329471&w=2
http://marc.info/?l=imp&m=105981180431599&w=2
http://marc.info/?l=imp&m=105990362513789&w=2

Solution :

Upgrade to IMP version 3.2.2 or later or apply patches found
in the announcements to imp/lib/MIME/Viewer/html.php.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)

Family: CGI abuses : XSS

Nessus Plugin ID: 11815 (imp_mime_viewer_html_xss.nasl)

Bugtraq ID:

CVE ID: