Apache < 2.0.43 Multiple Vulnerabilities (Log Injection, Source Disc.)

This script is Copyright (C) 2003-2012 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by an information discolsure
vulnerability.

Description :

The remote host appears to be running a version of
Apache 2.x which is older than 2.0.43.

Such versions are reportedly affected by an infomration disclosure
vulnerability. An attacker can exploit this vulnerability by making a
POST request to files in a folder with both WebDAV and CGI enabled.

*** Note that Nessus solely relied on the version number
*** of the remote server to issue this warning. This might
*** be a false positive.

See also :

http://www.apache.org/dist/httpd/CHANGES_2.0

Solution :

Upgrade to Apache web server version 2.0.43 or newer.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 4.3
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 11408 (apache_2_0_42.nasl)

Bugtraq ID: 6065

CVE ID: CVE-2002-1156
CVE-2003-0083