OpenSSL < 0.9.6j / 0.9.7b Multiple Vulnerabilities

This script is Copyright (C) 2003-2014 Tenable Network Security, Inc.


Synopsis :

The remote host has an application that is affected by
multiple vulnerabilities.

Description :

According to its banner, the remote host is using a version
of OpenSSL older than 0.9.6j or 0.9.7b.

This version is vulnerable to a timing-based attack that could
allow an attacker to guess the content of fixed data blocks and
may eventually be able to guess the value of the private RSA key
of the server.

An attacker may use this implementation flaw to sniff the
data going to this host and decrypt some parts of it, as well
as impersonate the server and perform man-in-the-middle attacks.

See also :

http://www.openssl.org/news/secadv_20030219.txt
http://eprint.iacr.org/2003/052/

Solution :

Upgrade to version 0.9.6j (0.9.7b) or newer.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 11267 ()

Bugtraq ID: 6884
7148

CVE ID: CVE-2003-0078
CVE-2003-0131
CVE-2003-0147