CUPS < 1.1.18 Multiple Vulnerabilities

This script is Copyright (C) 2003-2014 Tenable Network Security, Inc.


Synopsis :

The remote printer service has multiple vulnerabilities.

Description :

The remote CUPS server seems vulnerable to various flaws (buffer
overflow, denial of service, privilege escalation) that could allow a
remote attacker to shut down this service or remotely gain the
privileges of the 'lp' user.

Solution :

Upgrade to CUPS version 1.1.18 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true