Apache < 1.3.27 Multiple Vulnerabilities (DoS, XSS)

This script is Copyright (C) 2002-2012 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

The remote host is running a version of Apache web server older than
1.3.27. Such versions are reportedly affected by multiple
vulnerabilities :

- There is a cross-site scripting vulnerability caused by
a failure to filter HTTP/1.1 'Host' headers that are
sent by browsers.

- A vulnerability in the handling of the Apache scorecard
could allow an attacker to cause a denial of service.

- A buffer overflow vulnerability exists in the
'support/ab.c' read_connection() function. The ab.c file
is a benchmarking support utility that is provided with
the Apache web server.

See also :

http://archives.neohapsis.com/archives/bugtraq/2002-10/0195.html
http://archives.neohapsis.com/archives/vulnwatch/2002-q4/0012.html
http://archives.neohapsis.com/archives/bugtraq/2002-11/0137.html
http://archives.neohapsis.com/archives/vulnwatch/2002-q4/0003.html

Solution :

Upgrade to Apache web server version 1.3.27 or newer.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 11137 (apache_1_3_27.nasl)

Bugtraq ID: 5847
5884
5887
5995
5996

CVE ID: CVE-2002-0839
CVE-2002-0840
CVE-2002-0843