mod_python < 2.7.8 Module Importing Privilege Function Execution

This script is Copyright (C) 2002-2011 Thomas Reinke


Synopsis :

The remote web server is running a module that is vulnerable to
a code execution vulnerability.

Description :

The remote host is using the Apache mod_python module which is version
2.7.6 or older.

These versions allow a module which is indirectly imported by a
published module to then be accessed via the publisher, which allows
remote attackers to call possibly dangerous functions from the
imported module.

See also :

http://www.modpython.org/pipermail/mod_python/2002-April/012512.html
http://lwn.net/alerts/Conectiva/CLA-2002:477.php3

Solution :

Upgrade to mod_python 2.7.8 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 10947 ()

Bugtraq ID: 4656

CVE ID: CVE-2002-0185