Apache mod_ssl i2d_SSL_SESSION Function SSL Client Certificate Overflow

This script is Copyright (C) 2002-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server module has a buffer overflow vulnerability.

Description :

According to the web server banner, the remote host is using a
vulnerable version of mod_ssl. This version has a buffer overflow
vulnerability. A remote attacker could exploit this issue to execute
arbitrary code.

*** Some vendors patched older versions of mod_ssl, so this *** might
be a false positive. Check with your vendor to determine *** if you
have a version of mod_ssl that is patched for this *** vulnerability.

See also :

http://archives.neohapsis.com/archives/bugtraq/2002-02/0313.html

Solution :

Upgrade to mod_ssl 2.8.7 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 10888 ()

Bugtraq ID: 4189

CVE ID: CVE-2002-0082