Apache Auth Module SQL Injection

This script is Copyright (C) 2001-2014 Matt Moore


Synopsis :

The remote web server is affected by a SQL query manipulation
vulnerability.

Description :

The 'mod_auth_pgsql_sys' module is earlier than 0.9.6. Such versions are
reportedly affected by a SQL injection attack which could allow an
attacker to bypass authentication.

See also :

http://archives.neohapsis.com/archives/vulnwatch/2001-q3/0040.html

Solution :

Upgrade to mod_auth_pgsql_sys version 0.9.6 or newer.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 10752 (apache_auth_sql_insertion.nasl)

Bugtraq ID: 3251
3253

CVE ID: CVE-2001-1379