MySQL < 3.23.36 Multiple Vulnerabilities

This script is Copyright (C) 2001-2014 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The installed version of MySQL is older than version 3.23.36.
Such versions are potentially affected by multiple vulnerabilities :

- It is possible to modify arbitrary files and gain
privileges by creating a database with '..' characters.

- Users with a MySQL account can use the 'SHOW GRANTS'
command to obtain the encrypted administrator password
from the 'mysql.user' table. (CVE-2001-1275)

- Local users can modify passwords for arbitrary MySQL
users via the 'GRANT' privilege. (CVE-2000-0045)

See also :

Solution :

Upgrade to MySQL version 3.23.36 or later as this reportedly fixes the

Risk factor :

High / CVSS Base Score : 7.2
CVSS Temporal Score : 5.3
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 10626 ()

Bugtraq ID: 2380

CVE ID: CVE-2000-0045