oops WWW Proxy Server Reverse DNS Response Overflow

This script is Copyright (C) 2000-2014 Tenable Network Security, Inc.


Synopsis :

The remote proxy server is affected by a buffer overflow
vulnerability.

Description :

The remote server appears to be running ooops WWW proxy server version
1.4.6 or older. Such versions are reportedly affected by a buffer
overflow vulnerability. A remote attacker might exploit this
vulnerability to crash the server or execute arbitrary commands on the
remote system.

See also :

http://archives.neohapsis.com/archives/bugtraq/2000-12/0158.html

Solution :

Upgrade to the latest version of this software

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 10578 ()

Bugtraq ID: 2099

CVE ID: CVE-2001-0029