PHP File Upload Capability Hidden Form Field Modification Arbitrary File Access

This script is Copyright (C) 2000-2012 Tenable Network Security, Inc.


Synopsis :

Arbitrary files may be read on the remote host.

Description :

A version of PHP that is older than 3.0.17 or 4.0.3 is running on this
host.

If a PHP service that allows users to upload files and then display their
content is running on this host, an attacker may be able to read arbitrary
files from the server.

See also :

http://www.php.net/manual/language.variables.predefined.php

Solution :

Upgrade to PHP 3.0.17 or 4.0.3.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:U/RC:ND)

Family: Web Servers

Nessus Plugin ID: 10513 ()

Bugtraq ID: 1649

CVE ID: CVE-2000-0860