MariaDB 10 < 10.0.9 Multiple DoS Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple denial of service
vulnerabilities.

Description :

The version of MariaDB 10 installed on the remote host is a version
prior to 10.0.9. It is, therefore, potentially affected by denial of
service vulnerabilities due to errors related to the following :

- Union queries
- Prepare queries
- Join::prepare queries
- ONLY_FULL_GROUP_BY queries
- NAME_CONST queries

See also :

https://mariadb.atlassian.net/browse/MDEV-5505
https://mariadb.atlassian.net/browse/MDEV-5581
https://mariadb.atlassian.net/browse/MDEV-5617
https://mariadb.atlassian.net/browse/MDEV-5655
https://mariadb.atlassian.net/browse/MDEV-714

Solution :

Upgrade to MariaDB 10.0.9 or later or apply the vendor patch.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 72713 ()

Bugtraq ID: 65757

CVE ID: