MyBB < 1.6.11 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote web server contains a PHP application that is affected by
multiple vulnerabilities.

Description :

According to its version number, the MyBB install running on the remote
web server is affected by multiple vulnerabilities :

- A security bypass vulnerability exists due to improper
validation of the username during registration. This
issue only affects installs using a MySQL database.

- A flaw exists in which accounts without login keys can
be hijacked.

- The 'generate_post_check()' function in the
'functions.php' scripts contains an unspecified
weakness.

- A flaw exists that could make anonymous statistics not
always be anonymous.

- An information disclosure vulnerability exists related
to the database backups being exposed in logs.

Note that Nessus has not tested for these issues but has instead
relied on the application's self-reported version number.

See also :

http://www.nessus.org/u?1bc0e0c7

Solution :

Upgrade to version 1.6.11 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: CGI abuses

Nessus Plugin ID: 72686 ()

Bugtraq ID: 62933

CVE ID: