Core FTP Server < 1.2 Build 515 Multiple Vulnerabilities

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The FTP server running on the remote host is affected by multiple
vulnerabilities.

Description :

The version of Core FTP running on the remote host is prior to 1.2
build 515. It is, therefore, affected by multiple vulnerabilities :

- A denial of service vulnerability exists that is
triggered when handling malformed data after the 'AUTH
SSL' command. An unauthenticated, remote attacker can
exploit this to cause an assertion failure, resulting in
a server crash. (CVE-2014-1441)

- A information disclosure vulnerability exists due to a
failure to properly sanitize user-supplied input. An
authenticated, remote attacker can exploit this, via
directory traversal using the 'XCRC' command, to gain
access to arbitrary files. (CVE-2014-1442)

- An information disclosure vulnerability exists due to
improper handling of crafted string data by the 'USER'
command. An authenticated, remote attacker can exploit
this, via a specially crafted string, to access the
password for the user that previously logged on.
(CVE-2014-1443)

See also :

http://coreftp.com/forums/viewtopic.php?t=2985707
http://seclists.org/fulldisclosure/2014/Feb/39

Solution :

Upgrade to Core FTP version 1.2 build 515 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: FTP

Nessus Plugin ID: 72662 ()

Bugtraq ID: 65428
65430
65432

CVE ID: CVE-2014-1441
CVE-2014-1442
CVE-2014-1443