Drupal 6.x < 6.30 OpenID Module Account Hijacking

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server is running a PHP application that is affected by
a security bypass vulnerability.

Description :

The remote web server is running a version of Drupal that is 6.x prior
to 6.30. It is, therefore, affected by a security bypass vulnerability
in the OpenID module that could allow an authenticated attacker to
hijack other users' accounts. Only user accounts associated with one
or more OpenID entities are affected.

Note that Nessus has not tested for this issue but has instead relied
only on the application's self-reported version number.

See also :


Solution :

Upgrade to version 6.30 or later.

Risk factor :

Medium / CVSS Base Score : 6.0
CVSS Temporal Score : 5.2
Public Exploit Available : true

Family: CGI abuses

Nessus Plugin ID: 72102 ()

Bugtraq ID: 64973

CVE ID: CVE-2014-1475

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial