Winamp < 5.666 Multiple Memory Corruptions

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a multimedia application that is
affected by multiple memory corruption vulnerabilities.

Description :

The remote host is running Winamp, a media player for Windows. The
version of Winamp installed on the remote host is a version prior to
5.666. It is, therefore, reportedly affected by the following
vulnerabilities :

- A memory corruption error exists in 'in_midi.dll' when
processing specially crafted '.kar' files.

- A memory corruption error exists in 'libmp4v2.dll' due
to a NULL pointer dereference when processing specially
crafted files.

An attacker could exploit these vulnerabilities to cause a denial of
service.

See also :

http://www.winamp.com/help/Version_History
http://forums.winamp.com/showthread.php?t=373755

Solution :

Upgrade to Winamp 5.666 (5.6.6.3516) or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 71787 ()

Bugtraq ID: 63914

CVE ID: