Flash Player for Mac <= 11.7.700.252 / 11.9.900.152 Multiple Vulnerabilities (APSB13-28)

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on the
remote Mac OS X host is equal or prior to 11.7.700.252 / 11.8.x or
11.9.x equal or prior to 11.9.900.152. It is, therefore, potentially
affected by the following vulnerabilities :

- A type-confusion error exists that could allow
arbitrary code execution. (CVE-2013-5331)

- An input validation error exists that could allow
denial of service attacks or possibly arbitrary code
execution. (CVE-2013-5332)

See also :

http://helpx.adobe.com/security/products/flash-player/apsb13-28.html

Solution :

Upgrade to Adobe Flash Player version 11.7.700.257 / 11.9.900.170.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 71353 ()

Bugtraq ID: 64199
64201

CVE ID: CVE-2013-5331
CVE-2013-5332