Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Squid 3.x < 3.5.16, 4.0.x < 4.0.8 Multiple Vulnerabilities

High

Synopsis

The specific version of Squid that the system is running is reportedly affected by multiple vulnerabilities.

Description

The specific version of Squid that the system is running is reportedly affected by the following vulnerabilities:

- Squid contains an overflow condition in the Icmp6::Recv() function in icmp/Icmp6.cc of the pinger binary. The issue is triggered as user-supplied input is not properly validated when handling specially crafted ICMPv6 packets. This may allow a remote attacker to cause a buffer overflow, crashing the pinger process or potentially leaking data into log files. (CVE-2016-3947)

- Squid contains a flaw that is triggered as bounds are not properly checked when processing HTTP responses. This may allow a remote attacker to cause a denial of service for all clients accessing the service. (CVE-2016-3948)

Solution

Upgrade to Squid 3.5.16 or 4.0.8 or later.