icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

OpenSSL < 0.9.8za / < 1.0.0m / < 1.0.1h Multiple Vulnerabilities

Medium

Synopsis

The remote web server is running an outdated instance of OpenSSL and thus may be missing patches for multiple vulnerabilities.

Description

OpenSSL before 0.9.8za, 1.0.0m, or 1.0.1h are unpatched for the following vulnerabilities:

- Potential arbitrary code execution due to a buffer overflow vulnerability when processing invalid DTLS fragments (CVE-2014-0195)

- Denial of service via a NULL pointer dereference error in 'so_ssl3_write()' function of 's3_pkt.c' source file (CVE-2014-0198)

- Denial of service against an OpenSSL client due to a recursion flaw in the DTLS hadnshake. (CVE-2014-0221)

- A man-in-the-middle security bypass due to weak keying material in OpenSSL SSL/TLS clients and servers, which can be exploited via a specially crafted handshake (CVE-2014-0224)

- Denial of service that can be triggered in the case where anonymous ECDH ciphersuites are enabled in TLS clients (CVE-2014-3470)

Solution

Upgrade to OpenSSL version 0.9.8za or later, 1.0.0m or later, or 1.0.1h or later.