icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Mozilla / Firefox enablePrivilege Dialog Weakness

Low

Synopsis

The remote host is vulnerable to a Script Injection attack.

Description

The remote host appears to be running Mozilla or Firefox. It is reported that versions up to and including 0.9.3 of Firefox and up to and including 1.7.2 of Mozilla are prone to a security weakness in the enablePrivilege dialog that is displayed to authorize signed code execution. An attacker may display an arbitrary string in the security dialog to entice an user into executing a malicious script.

Solution

Upgrade or patch according to vendor recommendations.