icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

VLC Media Player < 2.0.2 Ogg_DecodePacket Function OGG File Handling Overflow

High

Synopsis

The remote host contains an application that is vulnerable to a buffer overflow vulnerability

Description

The remote host contains VLC player, a multi-media application.

Versions of VLC media player earlier than 2.0.2 are potentially affected by a heap-based buffer overflow vulnerability. An error exists in the function 'Ogg_DecodePacket' in the file 'modules/demux/ogg.c' that does not properly validate input and can allow a heap-based buffer overflow. Opening a specially crafted file can result in the execution of arbitrary code. (CVE-2012-3377)

Solution

Upgrade to VLC Media Player version 2.0.2 or later.