icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

MySQL < 5.0.40 IF Query NULL Dereference DoS

Medium

Synopsis

The remote database server is prone to a denial of service attack.

Description

The version of MySQL installed on the remote host is reportedly affected by a denial of service vulnerability that may be triggered with a specially crafted IF query. An attacker who can execute arbitrary SELECT statements may be able to leverage this issue to crash the affected service.

Solution

Upgrade to version 5.0.40 or higher.