icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

MySQL < 4.0.21 Multiple Vulnerabilities (2)

High

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running a version of the MySQL database that is older than 4.0.21.

MySQL is a database that runs on both Linux/BSD and Windows platforms. The remote version of this software is vulnerable to specially crafted ALTER TABLE SQL query that can be exploited to bypass some applied security restrictions or cause a denial of service.

To exploit this flaw, an attacker would need the ability to execute arbitrary SQL statements on the remote host.

Solution

Upgrade to version 4.0.21 or higher.