icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

PHP 5.3.7 crypt() MD5 Incorrect Return Value

High

Synopsis

The remote web server uses a version of PHP that is affected by a security bypass vulnerability.

Description

PHP version 5.3.7 contains a bug in the crypt() function when generating salted MD5 hashes. The function only returns the salt rather than the salt and hash. Any authentication mechanism that uses crypt() could authorize all authentication attempts due to this bug.

Solution

Upgrade to PHP version 5.3.8 or later.