icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

ProFTPD < 1.3.3g / 1.3.4 Response Pool Use-After-Free Code Execution

High

Synopsis

The remote FTP server is affected by a code execution vulnerability.

Description

The remote host is using ProFTPD, a free FTP server for Unix and Linux.

Versions of ProFTPD earlier than 1.3.3g / 1.3.4 are potentially affected by a code execution vulnerability due to how the server manages the response pool that is used to send responses from the server to the client. A remote, authenticated attacker, exploiting this flaw, could execute arbitrary code on the remote host subject to the privileges of the user running the affected application.

Solution

Upgrade to version 1.3.3g, 1.3.4, or later.