icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

SeaMonkey < 1.1.8 Multiple Vulnerabilities

High

Synopsis

A web browser on the remote host is affected by multiple vulnerabilities.

Description

The installed version of SeaMonkey is affected by various security issues :

- Several stability bugs leading to crashes that, in some cases, show traces of memory corruption

- Several file input focus stealing vulnerabilities that could result in uploading of arbitrary files provided their full path and file names are known.

- Several issues that allow scripts from page content to escape from their sandboxed context and/or run with chrome privileges, resulting in privilege escalation, XSS and/or remote code execution.

- A directory traversal vulnerability via the 'chrome:' URI.

- A vulnerability involving 'designMode' frames that may result in web browsing history and forward navigation stealing.

- Mis-handling of locally-saved plain text files.

- Possible disclosure of sensitive URL parameters, such as session tokens, via the .href property of stylesheet DOM nodes reflecting the final URI of the stylesheet after following any 302 redirects.

Solution

Upgrade to version 1.1.8 or higher.