icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Opera < 12.13 Multiple Vulnerabilities

High

Synopsis

The remote host has a web browser installed that is vulnerable by multiple vulnerabilities

Description

The remote host is running the Opera web browser.

Versions of Opera earlier than 12.13 are potentially affected by the following vulnerabilities :

- An error exists related to DOM manipulation that could lead to application crashes or arbitrary code execution. (1042)

- An error exists related to SVG 'clipPaths' that could lead to memory corruption or arbitrary code execution. (1043)

- The application could fail to make the proper 'pre-flight' Cross-Origin Resource Sharing (CORS) requests. In some situations this error could aid an attacker in cross-site request forgery (XSRF) attacks. (1045)

- An unspecified, low severity issue exists that has an unspecified impact.

Solution

Upgrade to Opera 12.13 or later.