icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Apache Tomcat 7.0.x < 7.0.22 Multiple Vulnerabilities

Medium

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

Versions of Tomcat 7.0.x earlier than 7.0.22 are potentially affected by multiple vulnerabilities:

- An information disclosure vulnerability exists. Request information is cached in two objects and these objects are not recycled at the same time. Further requests can obtain sensitive information if certain error conditions occur. (CVE-2011-3375)

- The web server is not properly restricting access to the servlets that provide the functionality of the Manager application. This can allow untrusted web applications to access privileged internal functionality such as gathering information on running web applications and deploying additional web applications. (CVE-2011-3376) IAVB Reference : 2012-B-0035 STIG Finding Severity : Category I

Solution

Upgrade to Apache Tomcat 7.0.22 or later.