icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Apache HTTP Server < 2.0.49 mod_ssl Plain HTTP Request DoS

Medium

Synopsis

The remote host is vulnerable to a Denial of Service (DoS) attack

Description

The remote host appears to be running a version of Apache 2.x which is older than 2.0.49. There is a bug in the mod_ssl module that ships with Apache 2.0.35 to 2.0.48 that makes it vulnerable to a remote denial of service. An attacker may exploit this flaw by issuing malformed SSL commands when connecting to the remote host, and may therefore use it to prevent HTTPS from working.

Solution

Upgrade to Apache/2.0.49 or later.